keep original file name when upload

Comments

3 comments

  • Avatar
    Aleksandar Kostadinov

    Hi Josh,

    I've taken a look at your request as Aditi is currently out of office.

    The reason why this is happening is that you have defined an upload preset in your account called "ml_default" with the setting "unique_filename" set to "true" what this does is tell Cloudinary to keep the original filename, but add random characters at the end (e.g. _geol5k) to ensure it is unique. This upload preset is set as the default for Media Library uploads based on the Settings in the account. What you can do is edit that upload preset and set the unique_filename flag to false and retry the upload.

    Let me know if this works for you once you've updated the preset.

    Best regards,

    Aleksandar

    1
    Comment actions Permalink
  • Avatar
    Aditi Madan

    Hi Josh,

    Cloudinary automatically adds random suffix to avoid duplicates. You can set use_filename= true in order to avoid this. This article outlines it in detail: https://support.cloudinary.com/hc/en-us/articles/202520762-How-to-upload-images-while-keeping-their-original-filenames-

    Thanks,
    Aditi

    0
    Comment actions Permalink
  • Avatar
    Josh

    I'm uploading media by drag and drop method on your site ... not used any script for uploading media !!

    0
    Comment actions Permalink

Please sign in to leave a comment.