image_tag only retreiving the public_id of the images

Comments

5 comments

  • Avatar
    Itay Taragano

    Please note that:

    1. The public ID can't start with a slash (`/`).
    2. The public ID should exclude the extension part (e.g., `.png`).

    Changing these two worked for me when trying it.

    How do you perform the upload? Server side or client-side?
    Can you share the cl_image_tag line of code you used?

    0
    Comment actions Permalink
  • Avatar
    Vincent Maurel

    Hi

    I finally found the problem by debugging the gem source code,

    I was passing the url of the image as first parameter instead of sending directly the property of my object 

    ie cl_image_tag(o.image.url) where I should write cl_image_tag(o.image)

    it worked then

    thanks for the precisions about the public_id I did not found these specifications in the documentation

    0
    Comment actions Permalink
  • Avatar
    Itay Taragano

    Thank you for the update, I'm glad it's working for you now :)

    You can have a look at the following for more information regarding the convention of the public_id:
    https://support.cloudinary.com/hc/en-us/articles/211665249-Legal-naming-conventions

    0
    Comment actions Permalink
  • Avatar
    Vincent Maurel

    I am getting a 

    "oops

    You're not authorized to access this page"

    when I click on your link

    https://support.cloudinary.com/hc/en-us/articles/211665249-Legal-naming-conventions

    0
    Comment actions Permalink
  • Avatar
    Itay Taragano

    My apologies, here's the correct link:

    https://support.cloudinary.com/hc/en-us/articles/115001317409--Legal-naming-conventions

    0
    Comment actions Permalink

Please sign in to leave a comment.